Logout

Alt-N Discussion Groups > MDaemon Discussion Groups > MDaemon Content Filter > Same email address in the from: and To fields:.

 [F] Alt-N Discussion Groups  / MDaemon Discussion Groups  / MDaemon Content Filter  /

Same email address in the from: and To fields:.

[m.capanni@grifonline.it]
m.capanni@grifo…
Newbie
Newbie
Posts: 65

MDaemon
SecurityPlus
WebAdmin
m.capanni@grifonline.it - 02:40am, Feb 21 2019

Hello everyone,

maybe I'm asking a silly question but I have a problem that I can not deal with.
In our Mdaemon server I have a rule for which I copy an incoming message to another email box.
Normally the rule works very well, however it rarely happens that the message reaches the legitimate recipient but is not copied to the second address.

This is the configured rule:

Rule 024
   RuleName = Copy INFO @
   Enable = Yes
   ThisRuleCondition = Any
   ProcessQueue = BOTH
   Condition01 TO = | contains | AND | info @ blabladomain |
   Action01 = copy to | "user @ blabladomain"

Now, I went to check the logs on the mdaemon server and found that the Content Filter did not process the aforementioned rule.
I also found that at one point of the mdaemon server logs these two lines seem to me inconsistent:

Received: from Accounting3 ([x.x.x.x])
    by smtpcmd01.ad.aruba.it with bizsmtp
    id eGQg1z00v1gwxG701GQiTA, Mon, 18 Feb 2019 17:25:36 +0100
From: "Gandalf" (gandalf@tolkien.za)
To: "Gandalf" (gandalf@tolkien.za)
Subject: Informations of goblins
Dates: Mon, 18 Feb 2019 17:24:40 +0100

I suppose the rule does not work for this reason, but in which case do I have an email address in both the From: field and the To: field?

Finally, the non-functioning of the rule could have other causes?

Thanks for any suggestions.

Max

  All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items

Edmund Cramp - Feb 22, 2019 12:37 pm (#1 Total: 3)  

 

Photo of Author
Edmund Cramp
Novice
Novice
Posts: 133

MDaemon
Outlook Connector
WebAdmin
Check the rule in CFRules.dat, if you have the text "info @ blabladomain" then it needs to have the spaces removed e.g. info@blabladomain

m.capanni@grifonline.it - Feb 25, 2019 6:16 am (#2 Total: 3)  

 

Photo of Author
m.capanni@grifo…
Newbie
Newbie
Posts: 65

MDaemon
SecurityPlus
WebAdmin
I checked the rule and it's correct, the spaces were added from the copy and paste into the editor.

Tyler Davis - Feb 25, 2019 4:50 pm (#3 Total: 3)  

Alt-N Technical Support  

Photo of Author
Tyler Davis
Frequent
Frequent
Posts: 326

MDaemon
RelayFax
SecurityGateway
Outlook Connector
SecurityPlus
ProtectionPlus
WebAdmin
The rule states that's it's looking for the desired data in the TO header. It doesn't matter what's in the FROM header as the rule doesn't take it into consideration.

If you'd like to find out where the message originated, you can search the SMTP-(in) log file for the message ID of the email.

The only reason MDaemon would not process a message through all content filter rules is if there was an earlier rule that has the action to stop processing rules or the message is system generated and MDaemon has been configured to not process these types of messages. See the link below to enable/disable this feature.

http://help.altn.com/mdaemon/en/index.html?preferences_miscellaneous.htm

--
Tyler Davis
MDaemon Technologies
https://www.mdaemon.com

---------------------------------------------------------------------
These forums are provided by MDaemon Technologies for user-to-user
support and discussion. MDaemon staff members may participate in the
forums periodically but please recognize that this is not the official
method of receiving technical support. To receive personal technical
support please use the form here:
http://www.altn.com/Support/RequestSupport/
---------------------------------------------------------------------



  All MessagesOldest ItemsOlder ItemsNewer ItemsNewest Items



 Content:

Read New | Search

 Guest:

Email to Admin



You are visiting as a Guest user.